Лайфхаки
January 21

Лайфхак #3: Автоматизация поиска выигрышных адресов в результатах вайтлиста

Автоматизация, но на половину. Решение для тех, кто не изобретает велосипед путем программирования всего подряд, а пробует решить базовые задачки через Excel. 😉

Составлено админом telegram-канала Профитик. Подписка и репосты - приветствуются. 😉

Алгоритм решения:

1️⃣ Создаем 4 столбца: выигрышные адреса, мои адреса, результат сравнения, количество выигрышных адресов.

2️⃣ Заполняем первые 2 столбца (данные у нас уже есть).

3️⃣ Третий столбец начинаем с формулы =СЧЁТЕСЛИ(A:A;B2) и копируем ее во все ячейки этого столбца. Копируем с помощью крестика в правом нижнем углу ячейки. Такое копирование динамически преобразует (A:A;B2) в (A:A;B3), (A:A;B4) и т.д.

4️⃣ В самую верхнюю ячейку 4 столбца вбиваем сумму прошлого с помощью функции =СУММ(C:C)

5️⃣ Натягиваем фильтр на три первые ячейки первой строки. Короче на все, кроме суммы выигрышных адресов.

Ну собственно и все.

Что делает функция СЧЁТЕСЛИ(A:A;B2)? Из синтаксиса видно, что она сравнивает ячейки из диапазона A:A с текущей ячейкой B2. Если есть пересечения, то функция возвращает их количество.

Как правило, тут будут всегда единицы либо нули. 1 - адрес зашел, 0 - адрес не зашел.

Что делает фильтр? С помощью фильтра мы можем отсортировать результаты и выигрышные адреса автоматически подвинуть на самый верх, чтобы с ними было удобно работать. Это экономит время, если ваших адресов тысячи (делегируются на помощников или скармливаются софту).

БЫЛО (БЕЗ СОРТИРОВКИ)

ПРИМЕНЯЕМ СОРТИРОВКУ

СТАЛО (С СОРТИРОВКОЙ)

Для тех, кто НИАСИЛИЛ... На основе данной статьи я создал готовый шаблон. Качайте, запускайте, подставляйте свои данные и пользуйтесь на здоровье!

➡️ Скачать готовый шаблон

Подходит также и для Google Docs.

P.S. Есть правда одна проблемка. Админы порой добавляют в список результатов лишние пробелы, табуляции, обрезают адреса. Как это быстро решать я тоже подскажу, но уже в другом лайфхаке. 😉

Статья составлена админом telegram-канала Профитик. Если вам нравится такой контент, то буду признателен за подписку или репосты. Буду стараться выпускать такое регулярно. И не только такое. Всех обнял, приподнял. 😉